
Q1.what is an application program? Explain how an application can be add/remove from 

a pc? 

Ans: An application program (sometimes shortened to application) is any program 

designed to perform a specific function directly for the user or, in some cases, for another 

application program. Examples of application programs include word processors; 

database programs; Web browsers; development tools; drawing, paint, and image editing 

programs; and communication programs. Application programs use the services of the 

computer's operating system and other supporting programs. The formal requests for 

services and means of communicating with other programs that a programmer uses in 

writing an application program is called the application program inter (API). 

 
Have you ever looked at all of the programs installed on your computer and wondered exactly 
why they are occupying precious hard drive space? Perhaps you recently discovered that the 
excessive number of "free" bundled programs came free for a reason, and you'd like to remove 
them now. Or maybe you just purchased new software that doesn't provide clear instructions 
about how to install it. If either or both of these scenarios are applicable to you, this article will 
help you remove programs that you don't want to store on your computer anymore and help you 
properly install the ones you want to keep.  
 
Windows Me, as well as some other versions of Windows, implements a helpful tool to facilitate 
the installation and removal of programs: Add/Remove Programs from the Control Panel (click 
Start, Settings, Control Panel).  
 
Many users aren't even aware of this tool because so many applications don't require its use for 
installation or uninstallation. Oftentimes, when a user inserts an application's CD-ROM into the 
disc drive, an "Autorun" file essentially jump-starts the program into action so the installation 
begins automatically. Or, if that isn't the case for a particular application, users can usually 
double-click My Computer on their Desktop, click the disc drive, and then browse through the CD-
ROM's files for the correct executable (.EXE) file they can double-click to launch the program's 
installation 
  

Q2. SUGGEST A SUITABLE OPERATING SYSTEM FOR THE FOLLOWING? 
ANS: 
The best OS for development is the one the developer feels most productive in. Generally 

speaking, it should be the same as the target for deployment, or be set up with a VM or 

access to another system that mimics the environment where the web application is to be 

deployed.  

There are some exceptions. For example, if the application is to be developed using 

Microsoft-proprietary technologies, you may have few options for development except 

on the Microsoft platform.  

If you, however, use more standard and universal technologies, the operating system is 

largely irrelevant save for the developer's own preference and productivity.  

Ring Topology 

In ring Network, every computer or devices has two adjacent neighbors for 

communication. In a ring network, all the communication messages travel in the same 

directory whether clockwise or anti clockwise. Any damage of the cable of any cable or 



device can result in the breakdown of the whole network. Ring topology now has become 

almost obsolete.  

FDDI, SONET or Token Ring Technology can be used to implement Ring Technology. 

Ring topologies can be found in office, school or small buildings.  

Star Topology 

In the computer networking world the most commonly used topology in LAN is the star 

topology. Star topologies can be implemented in home, offices or even in a building. All 

the computers in the star topologies are connected to central devices like hub, switch or 

router. The functionality of all these devices is different. I have covered the detail of each 

networking devices in the separate portion of my website. Computers in a network are 

usually connected with the hub, switch or router with the Unshielded Twisted Pair (UTP) 

or Shielded Twisted Pair Cables. 

Difference Between In Assembly and high Level Language 
 

Assembly language is used to write programs using the instruction set for a particular 

processor/controller.(example : 8051 or 8086 or MIPS).  

High Level Language is used to write programs using some grammer rules or languages 

created like C,PASCAL,FORTRN,JAVA.  

Assembly Language require an ASSEMBLER to convert the assembly code to machine 

level code(HEX CODE)  

High Level Language require a Compiler to convert into ASSEMBLY THEN machine 

level code.(Now-a-days compilers are smart enough to generate the machine code 

directly)  

To write assembly code it is necessary to know the architecture of the processor or 

controller.  

To write an High Level Program it is not neccessay to know the architecture completly.  

Assembly language is not protable.  

High Level Language is Portable. 

 

Q.5 Q5. EXPLAIN HOW WE CAN PROTECT YOUR MACHINE FROM 

COMPUTER  

VIRUSES.? 

Ans How To Protect Your Computer From Viruses 



Anti-virus software is a necessity today to ensure the security of your computer 
and personal information. It is essential that you understand how viruses get into 
your computer and know how to prevent them from getting in.  

Unfortunately for us, there are many people out there who get a rise out of writing small programs 
that find ways onto our computers and in most cases destroy personal file, data or steal out 
identity. This article explains some steps we can take to defend ourselves.  
 
What is a computer virus?  
 
A computer virus is a small program that piggybacks on legitimate programs. It is called a virus 
because it shares the traits of a biological virus where is passes from one computer to another in 
the same manner a biological virus passes from one person to another person. Once a computer 
virus is running, it can infect other programs and documents.  
 
Types of computer viruses:  
 
There are many types of viruses but the most common are:  
 
- Viruses: a small software program that attaches itself to other programs and/or documents  
- E-mail viruses: these viruses move around through email and usually replicates itself by 
automatically mailing itself to people in the victim's address book  
- Trojan horses: this is a computer program that claims to do one thing but instead does another 
such as erase your hard drive  
- Worms: this is a program that finds a small hole in computer network security and replicates 
itself on to other computers on that network.  
 
How does a virus get into our computer and how do they spread?  
 
Some of the most common ways a virus can get on your computer are:  
 
- Downloading a program from an unknown source and running it  
- Opening a file attachment from an e-mail  
- Sharing infected files from one computer to another on a floppy disk  
- Opening an electronic greeting card, audio and video files  
 
What are the signs of a virus, am I infected?  
 
- Your computer runs slower than normal  
- The computer stops or locks up  
- Your computer crashes and restart every few minutes  
- The computer restarts on its own and does not run properly  
- Applications on your computer do not run properly  
- Hard drives or disk are not accessible  
- Your computer cannot print properly  
- Unusual error messages appear  
- Menus and dialog boxes are distorted  
 
What kinds of damage can a virus do?  
 
The damage a computer virus can do depends on the type of virus it is. Here are some common 
threats.  
 

 



Ans-6 

Tables in MS-WORD 

A table consists of rows and columns that intersect to form cells. The cells can then be 

filled with text, numbers, graphics or formulas. After you create the table, you can 

modify it in a variety of ways:  

• by adding or deleting rows and columns  

• adjusting column width, sorting text, and  

• adding borders and shading  

The exercises below should familiarize you with many of these tasks.  

Inserting a Table 

Tables can be inserted anywhere in a document. If you are already working in a 

document, you can simply insert a table where needed. If the table will be the only item 

in your document, you can insert it first thing.  

To insert a table, place your insertion point where you would like the table to appear in 

your document. From the Table menu, select Insert Table. This brings up the Insert 

Table Dialog Box, which appears below.  

 

Figure 1: Insert Table Box 

The Insert Table box allows you to enter the number of rows and columns you need, as 

well as to specify the column width. If this is your first time inserting a table in Word, 

you may wish to use the Wizard Option. If you select this option, you will be led 

through the table creation process with a series of easy to follow steps. The Wizard 

option is intended for new users, and Word veterans will probably prefer to use the 

AutoFormat command.  

If you want to add formatting options to your table select AutoFormat. The AutoFormat 

Dialog Box allows you to change the format of the table by selecting one of the table 

templates shown in the window. If you do not want any special borders or shading in 

your table, you can select OK and the table will be inserted in your document. Remember 

that you may go back at any time and add formatting to your table. Exercise one walks 

you through creating and inserting a table.  

Exercise 1: creating and inserting a table 

In this exercise you are going to create a table which contains the names and addresses 

for a hockey team.  



1. Select Insert Table from the Table menu.  

2. For the time being ignore the row and column sections and press the Wizard 

button.  

3. Once Wizard has loaded select Style 1 as your table format, and press Next.  

4. You are presented with several more options; for this exercise, choose the 

following:  

o no headings, 5 columns  

o use numbrs for headings on rows (1 to 10)  

o center row headings  

o text in rows should be left aligned  

o table will be oriented in portrait  

5. Click on Finish  

6. When the Wizard closes, the AutoFormat menu allows you to edit the border or 

shading. Choose none and click OK.  

We chose style one since it gives us a very basic table. You can go back and add some 

fancy formatting features, like the ones you observed in the other Style choices.  

 
1 Tom Jones 555 Lochmere Dr. Cary, NC 27511 919-467-7777 

2 Annie Dog 555Yadkin Dr. Raleigh, NC 27609 919-782-5555 

3 Alex Boy 1212 Carriage Dr. Raleigh, NC 27612 919-781-1111 

4 Jordie Haywood 1111 Big Woods Chapel Hill, NC 919-541-1111 

5     

6     

7     

8     

9     

10     

b). Mail merge in MS word 

Mail merge is a very important facility provided by word processors, especially in 

the world of business and commerce. A single document (often a letter) is merged 

with a data set (often names and addresses) to produce several documents, each 

of which is personalised using information from the data set. Find out how to use 

this feature with Word.  

Using mail merge, you can create: 

 A set of labels or envelopes   The return address is the same on all the labels or envelopes, 

but the destination address is unique on each one.  



 A set of form letters, e-mail messages, or faxes   The basic content is the same in all the 

letters, messages, or faxes, but each contains information that is specific to the individual recipient, 

such as name, address, or some other piece of personal data.  

 A set of numbered coupons   The coupons are identical except that each contains a unique 

number.  

Creating each letter, message, fax, label, envelope, or coupon individually would take hours. That's where 

mail merge comes in. Using mail merge, all you have to do is create one document that contains the 

information that is the same in each version. Then you just add some placeholders for the information that is 

unique to each version. Word takes care of the rest. 

c). Header and Footer 

The way to access headers and footers is to go to the View menu, and choose Header and 
Footer from the list. 

Whatever we insert into the header and footer area will become the header or footer for the whole 
document (unless we use some of the page setup options discussed below). 

 

In the box you may insert text, date/time stamps, pictures, etc. Just about anything you put into a 
document can be put into the header or footer area. (The box will expand in size to accommodate 
your information. Keep in mind that the larger the header or footer, the smaller the document 
body becomes.) 

Finished with the header? Ready to move on to the footer? Simply click on the Switch Between 
Header and Footer button and enter the information you want.  

 

So there are the very basics. What about all the other stuff on the Header and Footer toolbar you 
ask? Well, let me tell you... 

Starting from the left, the first button is to Insert Auto Text. This is a pull-down menu of choices. 
Choosing something from the list will automatically insert the information suggested including 
dates, times and any author information the program may have. (It usually has information on the 
owner/author from the installation process.) 



The second group contains buttons that are all related to inserting page numbers and the number 
of pages as well as formatting the page number. Simply put your mouse cursor over the button 
and let it sit for a second. The name of the button will pop-up. You'll find that most buttons are 
self-explanatory. Should you accidentally insert something you don't like, delete it or use the undo 
button, just like all editing in Word documents. 

Next, you'll find a set of two buttons that will Insert Date and/or Time. 

Buttons for accessing a document's Page Setup and Showing/Hiding Document Text are 
contained in the fourth section of the toolbar.  

The Page Setup window will bring you straight to the tab that contains header and footer 
choices. Here you will find an option for having different headers and footers on odd and even 
pages as well as an option for having a different header on the first page.  

 

Keep in mind that when you choose to have different headers and footers on odd and even pages 
you will need to go into the document and set them up on both an odd and an even page. If you 
choose to have a different header on the first page only you will need to set up the first page and 
then the other pages. 

At the far right end, there are buttons for navigating through your headers and footers. The Show 
Next and Show Previous buttons will move you page by page through the document. 

The Close button will close your headers and footers toolbar and place your cursor back in the 
body of the document. Now the headers and footers are set and can not be changed unless you 
specifically access the header/footer area again. (You can also simply double click in the body of 
the document to close the Header / Footer boxes). 

In the Normal view of the document, you will no longer see the headers and footers, but rest 
assured, they're in the document and will print. To access them again simply go to the View 
menu, Header and Footer choice. 

If you prefer the Page Layout view, then you will still see the headers and footers. You will find 
that they are written in a light gray in the appropriate places. You can access them again in one of 



two ways. First, you can return to the View menu, Header and Footer choice. The second option 
is to double-click in any header or footer. Double clicking will dim the body of the document, 
bring up the header and footer toolbar and allow you to edit. 

d).Bullets and numbering in MS Word 

In Word, we can add bullets to existing lines of text, or we can automatically create bulleted lists as 
we type. 

Method 1: Add bullets or numbering to existing text 

To add bullets or numbering to a list of existing text items, follow these steps:  
 
1. Start Word, and then open your document. 
2. Select the list items to which you want to add bullets or numbering. 

3. On the Formatting toolbar, do one of the following:  

• Click the Bullets button if you want to add bullets. 

• Click the Numbering button if you want to add numbering. 

The default (or the currently selected) bullet or number format is added to the list items.  

Method 2: Add a bulleted or numbered list format to existing text 

You can use a bulleted or numbered list format to add bullets or numbering to a list of existing text 
items. To do this, follow these steps:  

1. Start Word, and then open your document. 
2. Select the list items to which you want to add bullets or numbering. 
3. On the Format menu, click Bullets and Numbering, and then do one of the following:  

• Click the Bulleted tab if you want to add bullets. 

• Click the Numbered tab if you want to add numbering. 

 
4. Click the bulleted or numbered list format that you want, and then click OK. 
 

The bulleted or numbered format is added to the list items. 

Method 3: Create a bulleted list or numbered list as you type 

If you have not started a list yet, you can create a bulleted list or a numbered list automatically as 
you type. To do this, follow these steps:  
1. Start Word, and then open your document. 
2. Do one of the following, as appropriate to your version of Word:  

• In Word 2000, click AutoCorrect on the Tools menu, and then click the AutoFormat As You 

Type tab. 

• In Word 2002, click AutoCorrect Options on the Tools menu, and then click the AutoFormat 

As You Type tab. 
 
3. Under Apply as you type, do one or both of the following, and then click OK:  

• Click to select the Automatic bulleted lists check box (if it is not already selected). 

• Click to select the Automatic numbered lists check box (if it is not already selected). 

 
4. Do one of the following:  

• Type 1. if you want to start a numbered list. 

• Type * (the asterisk character) if you want to start a bulleted list. 

 
5. Press the SPACEBAR key. 
6. Type your text, and then press ENTER. 
 
Word automatically inserts the next number or bullet at the beginning of the line. 
7. Repeat step 6 to create additional list items. 

8. To finish the list, press ENTER twice. 

 



Method 4: Outline numbered lists and outline bulleted lists 

Create an outline numbered list 

To create an outline numbered list, follow these steps:  
1. Start Word, and then open your document. 
2. On the Format menu, click Bullets and Numbering, and then click the Outline Numbered 
tab. 

3. Select any list style in the top row, and then click OK. 
 
NOTE: Do not select a style that contains the text "Heading 1". 
 
The first number of the list is displayed in your document. 
4. Type your list text; be sure to press ENTER after each item. 
 
Word automatically inserts numbers in sequence at the beginning of each line at the first level. 
5. To move an outline numbered item to the level that you want, do one of the following:  

• To demote an item to a lower level, select the item, and then click Increase Indent. 

• To promote an item to a higher level, select the item, and then click Decrease Indent. 

 
The item is moved to the level that you specify, and the appropriate numbering level is inserted at 
the beginning of the line. 
 

 

 

 

 

 


